備忘録/にわかエンジニアが好きなように書く

個人的にとりあえず仕組みを知るために、触りたように好きにとりあえず動くような構築してみる 個人用の備忘録となるので内容の保証はないのでその点はご了承ください。 ※変な内容や間違いを書いているなどありましたらコメントやご指摘いただけると幸いです。

【Dell Nシリーズ】 基本コマンドと初期設定

 

基本設定

モード遷移

オペレーションモードへ

console>enable

console#

 コンフィグモードへ

console#configure terminal

console(config)#

 

console(config)#exit

console#exit

console>

ホスト名設定

console(config)#hostname HostA
 
HostA(config)#

ユーザ設定

ユーザ名:user01 , パスワード:password01

console(config)#username user01 password password01 privilege 15

時間設定

タイムゾーン
console(config)#clock timezone +9
  手動日時設定
console(config)#clock set 14:00:00
console(config)#clock set 6/1/2019
  NTPサーバ設定
console(config)#sntp server 1.2.3.4 poll
console(config)#sntp unicast client enable

リモート接続

Telnet

無効化 ※デフォルトは有効

console(config)#no ip telnet server disable

 有効

console(config)#ip telnet server disable
SSH
console(config)#crypto key generate rsa
console(config)#crypto key generate dsa
console(config)#ip ssh server
HTTPS
console(config)# ip https authentication local 
console(config)# crypto certificate 1 generate
console(config-crypto-cert)#key-generate
console(config-crypto-cert)#exit
console(config)# ip https server

管理ポートへのIPアドレス設定

console(config)#interface out-of-band
console(config-if)#ip address 192.168.100.100 255.255.255.0

VLAN

VLAN設定
console(config)#vlan 100
console(config-vlan100)#name VLAN100
console(config-vlan100)#exit
console(config)#
 VLANインターフェース設定
console(config)#interface vlan 100
console(config-if-vlan100)#ip address 192.168.0.254 255.255.255.0
console(config-if-vlan100)#exit
console(config)#
VLAN設定(AccessMode)
console(config)#interface gigabitethernet 1/0/1
console(config-if-Gi1/0/1)#switchport mode access
console(config-if-Gi1/0/1)#switchport access vlan 100
console(config-if-Gi1/0/1)#exit
console(config)#
VLAN設定(Trunk Mode)
console(config)#interface gigabitethernet 1/0/2
console(config-if-Gi1/0/2)#switchport mode trunk
console(config-if-Gi1/0/2)#switchport trunk allowed vlan 100
console(config-if-Gi1/0/2)#exit
console(config)#

ルーティング

console(config)#ip routing

デフォルトルート設定

ルーティング有効時

console(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.1

 ルーティング無効時

console(config)#ip default-gateway 192.168.0.1

LAG設定

console(config)#interface range gigabitethernet 1/0/23-24
console(config-if)#channel-group 1 mode on
console(config-if)#exit

■LACPの場合
console(config-if)#channel-group 1 mode active
チャネルグループ設定
console(config)#interface port-channel 1
console(config-if-Po1)#spanning-tree disable
console(config-if-Po1)#switchport mode trunk
console(config-if-Po1)#switchport trunk allowed vlan 100
console(config-if-Po1)#exit
console(config)#